SGI IRIX 6.4.x run-time Linker creates vulnerabilities in arbitrary files

Summary

SGI IRIX version 6.4 has an arbitrary file creation vulnerability that allows low-privileged users or malicious programs to create the contents of any file on the target host.

Solution

At present, the manufacturer does not provide the repair solution, please pay attention to the manufacturer's home page:

https://www.hpe.com/us/en/solutions/hpc-high-performance-computing.html